This is going to possibly piss off a lot of half-assed plugin developers. But it’ll also be a big fucking deal if it makes it into 3.7 unscathed.