Considering an upgrade to PHP 5.5.x? It’s dangerous to go alone! Take this.